High rate of errors and connection failures to Fitbit API

Incident Report for Fitabase

Resolved

The issue has been resolved. Today we worked closely with the team at Google to identify the issue and once it was resolved, we re-queued data pulls into Fitabase. That has now completed. Any profiles connected during the outage should now have missing data filled in.
Posted Apr 29, 2026 - 19:24 PDT

Identified

Fitabase is temporarily unable to connect with the Fitbit API for many profiles. We're working with our engineering contacts at Google / Fitbit to help identify the issue.
Posted Apr 29, 2026 - 07:20 PDT
This incident affected: Web App, Fitbit Syncing, and API.