Major Fitbit Outage

Incident Report for Fitabase

Resolved

Fitbit has resolved the issue. We have confirmed data is flowing successfully through our system.
Posted Jul 17, 2025 - 09:58 PDT

Investigating

Fitbit is currently investigating a major outage in their system.
Posted Jul 17, 2025 - 05:43 PDT
This incident affected: Web App, Fitbit Syncing, and API.