Potential for Missing Minute Level Date for Steps, Intensity, Mets, and Calories
Incident Report for Fitabase
Resolved
We have completed backfilling the minute level steps, calories, intensity, and METs data for affected profiles. Customers should now see any missing data that would have been captured during 6/25-7/15. Please reach out to support@fitabase.com if you have any concerns about your data not appearing to be complete.
Posted Jul 17, 2024 - 16:01 PDT
Identified
There was an uncommunicated change applied on June 25th, 2024 in how the Fitbit API requires Fitabase to make minute-level data calls. We are updating our code to align with those new requirements and will be working over the next day or two to make sure the minute-level data is appearing into the platform.

Fitabase on July 15th, 2024 pushed a fix to backfill the minute-level data that was not showing up for actively-syncing participants.
The affected data is minute-level only for the following data types:
* Steps
* Intensity
* METs
* Calories

If you need to backfill this data urgently, you can navigate to an individual participant's sync dates (found within Participant Details) and without changing the sync dates, click "Update Sync Dates". This will run a backfill.

This week we will re-run data pulls for all active profiles during this time, so no additional steps are required by customers. Minute-level data for participants whose sync dates ended before June 25, 2024 should already be in the platform (as this API call change occurred after that date).
Posted Jul 15, 2024 - 16:59 PDT
This incident affected: Fitbit Syncing.