Google has reported an outage affecting Sync functionality for all Google Health users.

Incident Report for Fitabase

Resolved

The outage has been resolved and all Fitbit data should now be caught up in Fitabase.
Posted Jul 15, 2026 - 14:27 PDT

Investigating

Device sync and pairing are affected. It appears this is also impacting the ability to connect participants in Fitabase. We will monitor this issue and resolve any impacted syncing data once Google reports the outage has been resolved.
Posted Jul 15, 2026 - 08:23 PDT
This incident affected: Fitbit Syncing.